Xabi

[GAMEMODE] WiredPlayers Roleplay Server

Recommended Posts

-> Error starting 'WiredPlayers'
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.IO.FileNotFoundException: Could not load file or assembly 'System.Text.Encoding.CodePages, Version=4.1.1.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'. O sistema não pode encontrar o arquivo especificado.
   at void WiredPlayers.database.Database.OnResourceStart()
   --- End of inner exception stack trace ---
   at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
   at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)
   at GTANetworkInternals.ScriptingEngine.InvokeVoidMethod(String method, Object[] args)
   at System.Collections.Generic.List`1.ForEach(Action`1 action)
   at GTANetworkInternals.EventHandler.ParseEx(Event _event, ScriptingEngine engine, Object[] arguments)
   at System.Collections.Generic.List`1.ForEach(Action`1 action)
   at GTANetworkInternals.GameServer.StartResource(String resourceName, String parent)

How I fix this? I compiled the solution and the WiredPlayers

Share this post


Link to post
Share on other sites
5 minutes ago, andregamma said:
-> Error starting 'WiredPlayers'
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.IO.FileNotFoundException: Could not load file or assembly 'System.Text.Encoding.CodePages, Version=4.1.1.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'. O sistema não pode encontrar o arquivo especificado.
   at void WiredPlayers.database.Database.OnResourceStart()
   --- End of inner exception stack trace ---
   at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
   at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)
   at GTANetworkInternals.ScriptingEngine.InvokeVoidMethod(String method, Object[] args)
   at System.Collections.Generic.List`1.ForEach(Action`1 action)
   at GTANetworkInternals.EventHandler.ParseEx(Event _event, ScriptingEngine engine, Object[] arguments)
   at System.Collections.Generic.List`1.ForEach(Action`1 action)
   at GTANetworkInternals.GameServer.StartResource(String resourceName, String parent)

How I fix this? I compiled the solution and the WiredPlayers

If you made it in the same order as the guide says, you'd have the correct version for that .dll library. You need the one on Github, not the one comming with the bridge.

Share this post


Link to post
Share on other sites
8 minutes ago, Xabi said:

If you made it in the same order as the guide says, you'd have the correct version for that .dll library. You need the one on Github, not the one comming with the bridge.

Thanks, I finally started the server

Share this post


Link to post
Share on other sites
26 minutes ago, andregamma said:

But, I spawned on RageMP spawn point, and not teleport to a house or something, and my account is not registered on database.

Show the full log file / console, it didn't load the gamemode.

Share this post


Link to post
Share on other sites

Initializing Bootstrapper.dll (0.3.5.1)..
-> SERVER STARTED AT 05.12.2018 20:35:41
Loaded 451 entries from vehicleData.json
Loading resources..
-> Starting WiredPlayers resource..
WiredPlayers: setting as Gamemode resource
WiredPlayers: loading scripts.. found 1 script(s)
WiredPlayers: warning, bin/Debug/netcoreapp2.1/WiredPlayers.dll is not found!
-> Resource WiredPlayers started!
Started! Waiting for connections..

 

 

and server.exe shoutdown why ?

Share this post


Link to post
Share on other sites
1 hour ago, Vize1610 said:

Initializing Bootstrapper.dll (0.3.5.1)..
-> SERVER STARTED AT 05.12.2018 20:35:41
Loaded 451 entries from vehicleData.json
Loading resources..
-> Starting WiredPlayers resource..
WiredPlayers: setting as Gamemode resource
WiredPlayers: loading scripts.. found 1 script(s)
WiredPlayers: warning, bin/Debug/netcoreapp2.1/WiredPlayers.dll is not found!
-> Resource WiredPlayers started!
Started! Waiting for connections..

 

 

and server.exe shoutdown why ?

WiredPlayers: warning, bin/Debug/netcoreapp2.1/WiredPlayers.dll is not found!

 

Just compile the gamemode.

7 hours ago, andymoriarty said:

I installed the gamemode, it all started, but when I log in to the server, it says: "Connection lost. Reconnecting"
How I fix this?

Server crashed? Can you connect other servers? Did you open the required ports?

Share this post


Link to post
Share on other sites
vor 12 Minuten schrieb Xabi:

WiredPlayers: warning, bin/Debug/netcoreapp2.1/WiredPlayers.dll is not found!

 

Just compile the gamemode.

what compile? WiredPlayers.csproj ? and with what?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.