AimWolf

Eigene Scrips benutzen

Recommended Posts

Hallo zusammen,

ich habe ein kleines Problem wenn ich versuche eigene Scrips in einen Server einzubinden. Lokal funktioniert alles einwandfrei aber wenn es versuche auf den öffentlichen Server hochzuladen (Zap-Hosting über Filezilla) lädt er zwar das Script herunter, aber er führt es nicht aus. Könntet ihr mir vielleicht sagen welche Datei ich in welches Verzeichnis machen muss? Hier noch alle Infos:

Filezilla Tree:

-gta5-ragemp

--client_packages                                                                                                                                               ---.listcache

--maps

--packages

--plugins
---bridge.so

Code des Scriptes in C#:

using System;
using GTANetworkAPI;

namespace firstresource
{
    public class Main : Script
    {
        public Main()
        {
            Console.WriteLine("Hello World!");
        }

        [Command("test")]
        public void CMD_Test(Client client)
        {
            client.SendChatMessage("Hello There!");
        }
    }
}

Meta XML:

<meta>
  <info name="My First Resource" author="Julian" type="script" />
  <script src="compiled/netcoreapp2.2/firstresource.dll"/>
</meta>

Ich hoffe euch reichen die Infos und ihr könnt mir helfen. Falls ihr noch mehr Fragen habt stelle ich euch die Infos gerne schnell zur Verfügung. Danke schon im Voraus!

LG

AimWolf

Share this post


Link to post
Share on other sites

Heyo,

 

was hast du denn in deiner settings.xml im Bridge Ordner stehen?

Share this post


Link to post
Share on other sites

Hallo,

ich habe folgendes hineingeschrieben:

<?xml version="1.0"?>
<config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
  <acl_enabled>false</acl_enabled>
  <resource src="firstresource" />
</config>

 

ich hoffe das hilft weiter.

Share this post


Link to post
Share on other sites

Windows Server?!

 

Dann verpack dein Ordner in einer .zip oder .rar, öffne den Remotedesktopverbindung und zieh es einfach rüber und entpack es dann.

Versuche Rechtsklick auf den Ordner und dann schau unter Eigenschaften ob da ein Haken in "Schreibgeschützt" drinnen ist wenn ja dann mach ihn raus.

Share this post


Link to post
Share on other sites

Nein ich habe einen Linux Server. Mittlerweile haben wir das Problem behoben. Es lag am Provider. Trotzdem danke für die Antworten.

LG

AimWold

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.