Jump to content

How to use an Xbox Controller on Rage MP / Grand RP


Raiden Knight

Recommended Posts

Hi

How do you get an Xbox controller to work correctly when accessing an RP server using Rage MP (Grand RP to be precise)

The controller kind of works in some areas like walking around, driving certain vehicles but some parts it just doesn't work which is strange being that the main core engine supports a controller and there are controller options within the games settings menu when playing RP.

It doesn't work when trying to hold a gun and shoot, you get the gun out which the character holds you then move the right thumb stick and the gun disappears, yet if you walk into a store it will ask you to put your gun away even though you don't see it and doesn't look like you are holding anything.

You cant aim with a gun either when using a controller.

You also cant drive the fire engine with a controller its really strange what happens with that one, its impossible.

I have tried apps like reWASD which kind of makes some things a little better its still very intermittent though.

I know a lot of people use KB and Mouse but this is something I have never used and seems so alien to me trying to use both when I am so comfortable with a controller.

I have tried these controllers and they all behave the same.
Xbox One
Xbox 360
Xbox Series X
PS4 Dual Shock

I have searched the web and cant find a definitive answer on how to do this only that people are experiencing the same issues as I am.

I would appreciate anyone's help

 

My GTA is Steam with Rockstar Game Launcher if that helps.

 

Many thanks and have a blessed day.

 

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...