Sign in to follow this  
Hanvod

Let CEF use microfone

Recommended Posts

It seems like CEF doesnt allow me to use my microfone.

<!DOCTYPE html>
<html>
  <head>
    <meta charset="UTF-8">
    <meta name="viewport" content="width=device-width, initial-scale=1.0"/>
    <title></title>
<body>
<h1 id="a">123</h1>
<h1 id="b">123</h1>
<h1 id="c">123</h1>
<h1 id="d">123</h1>
<script>
document.getElementById("a").innerHTML = navigator.getUserMedia
document.getElementById("b").innerHTML = navigator.webkitGetUserMedia 
document.getElementById("c").innerHTML = navigator.mozGetUserMedia
navigator.webkitGetUserMedia({audio: true}, function(stream) {document.getElementById("d").innerHTML = stream}, function() {})
</script>
</body>
 </html>

First screenshot: Google Chrome, microfone using alowed, getUserMedia() and webkitGetUserMedia() exists,  everything works fine

pwtCvgH.png

Second screenshot: Google Chrome, microfone not alowed, getUserMedia() and webkitGetUserMedia() exists, stream is null, like it expected to be.

kd8tqHP.png

Third screenshot: CEF in-game, getUserMedia() and webkitGetUserMedia() exists, but stream is null like if my microfone is disabled for some reason.

2dN3ZHn.png

Question: how to enable microfone inside CEF?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.