Jump to content

Clientscript error Undefined 0


Recommended Posts



Actually i always got this error and after some try i can go on the server (Ad Astra) with no problems. Sometime it took me 1 try sometimes 20-30 try ! 



Right now there isn't a clear answer in this, however, some have fixed by allowing RageMP through their firewall, and some fixed it by closing all programs on their computer to free up their RAM/CPU and then loading into a server.


The problem is my RAM 16 GO is never high % ... Even if i close all my programs it's still the same i cant connect to any servers.


Ive got Bitdefender on my computer, i never had a firewall autorisations problems before ... To the meantime i white listed all RageMP programs, etc etc and even the Ipadress of Ad Astra.

Maybe someone got the same problem as my and can help me !



Link to comment
Share on other sites

This error happens due to an unknown reason currently.

Temp/Possible fixes:
1) go to client_resources/ip:port of the server and delete that folder.

2) Restarting the game sometimes work.

3) Making the game as windowed mode sometimes avoids the issue.

  • Like 1
Link to comment
Share on other sites

Yeah, I stopped being able to connect weeks ago. I ALWAYS get undefined:0 -- I've tried all the fixes and have a top of the line PC. Restarting PC & game/reinstalling ragemp & GTA 5/deleting content inside client_resources folder, running as admin, added exception through firewall and windows defender (current antivirus), launching as windowed and being alt-tabbed. Maybe in 30 attempts I can connect, but decided it's not worth it just to play for an hour or two. So... going to wait and pray it's fixed in these upcoming updates.


Link to comment
Share on other sites

Some have also said if you're alt tabbed out of the game while it's loading (both gta v loading screen and server loading) that it won't happen.


undefined:0 like said above is something that doesn't have a 'fix' because nobody is sure why it occurs, it only happens for some but not everyone.

  • Like 1
Link to comment
Share on other sites

  • 3 weeks later...


Avoid RageMP crashes / bugs
Rage-MP needs a clean installation to avoid some crashes. And yes, not everything is necessarily perfect. For that a solution is present and you must do it to correct many details.

Go to Documents.
Find the Rockstar Games folder.
Rename the Rockstar Games folder to Rockstar Games_OLD.
Restart RageMP and choose Local Backup and not the cloud.

If you want to replay in solo mode with your old backup, you can reuse the old one. RageMP requires a 100% new installation, with nothing on it to fix many problems.

If the manipulation above does not work, you must also delete the cloud:

(Warning this manipulation will erase all your backups of the Solo mode and you will have to redo the first missions to access the Online mode)

Launch GTA 5 Solo
Once in play, "ESC" then tab "GAME" then choose "load"
Select each backup and make "Space" to delete the backup (s).
Close your game

(Tutorial from french server AdAstra)
See ya

Edited by Balbz
Link to comment
Share on other sites

  • 7 months later...
3 hours ago, tonihenkel said:

Most when you restart your game one time, the message is hidden ;)

The fix was already specified in a post above, wasn't needed for you to revive an almost one year old thread.

Edited by robearded
Link to comment
Share on other sites

  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...