Jack Smith

Fehler Map Editor 0.3 für Rage

Recommended Posts

Hallo zusammen,

weiß jemand das Problem zu lösen beim Karteneditor für Rage auf dem eigenen Server zu lösen. Haben den Editor installiert und sobald man conected und die F2 taste drückt, bricht er ab!

Die Fehlermeldung erscheint: https://imgur.com/a/vbpjz8O

Kann mir jemand dabei helfen :( pls

 

Share this post


Link to post
Share on other sites

Der Editor ist nicht auf dem Aktuellen Patch Stand von Rockstar. Dort haben sich einige Natives geändert. Diese müsste man auf den aktuellen Stand bringen.

Falls ich dazu komme schaue ich heute Abend mal ob ich die finde.

Share this post


Link to post
Share on other sites

Sorry hat etwas länger gedauert. Bitte mal Folgendes Probieren.

Den Inhalt der Datei client_packages\MapEditor\Natives.js ersetzen mit

const __Natives__ = {
    SET_ENTITY_ALPHA: ['0x93271EC996EE94D2'],
    RESET_ENTITY_ALPHA: ['0x2087B43C7787E236'],
    GET_ENTITY_MODEL: ['0x4F69FBD64CDF125B']
};

const proxyNatives = new Proxy(__Natives__, {
    get: (target, name, receiver) => __Natives__[name][0]
});

exports = proxyNatives;

 

Share this post


Link to post
Share on other sites

@Pandoryhat leider nicht geklappt!! Danke Dir trotzdem für deine Mühen! 

wenn du vielleicht mal Zeit hast zu uns ins TS zu kommen und vielleicht kannst du uns da helfen!!! :)

LG 

Share this post


Link to post
Share on other sites

Muss jetzt am Wochenende selber mal schauen, war der Meinung das ich den Editor zum laufen bekommen hatte. Hatte die Natives neu Zusammen gesucht aber irgendwo auf der Platte müsste ich noch die Version haben.

TS könnte ich mal machen, allerdings bin ich kein Profi der sich mit allem gut auskennt. Suche mir auch immer alles zusammen ^^

Share this post


Link to post
Share on other sites
const __GameVersion__ = 0;

const __Natives__ = {
    SET_ENTITY_ALPHA: ['0x44A0870B7E92D7C0'],
    RESET_ENTITY_ALPHA: ['0x9B1E824FFBB7027A'],
    GET_ENTITY_MODEL: ['0x9F47B058362C84B5']
};

const proxyNatives = new Proxy(__Natives__, {
    get: (target, name, receiver) => __Natives__[name][__GameVersion__]
});

Versuch das mal.


 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.