Sign in to follow this  
Seminglo

Server crash on startup with just "Aborted" text

Recommended Posts

I already asked from Discord, didn't get much far there. Thanks for foxpro and Georg to help as much as they could though.

But heres my problem:
"Aborted" comes when NAPI vehicle is created.

Starting RAGE Multiplayer server...
[=================]
        MaxPlayers:             500
        Sync rate:              40
        Name:                   EESTI GTAV.ee KOMMUUN - TEST
        Gamemode:               roleplay
        Streaming distance:     500
        Announcement:           enabled
        Voice chat:             disabled
        Address:                127.0.0.1:22005
        Connection limits:      disabled
        Encryption:             disabled
        NodeJS:                 enabled
        C#:                     enabled
[=================]
[N] Starting network... - OK: (IPv4-only) at 127.0.0.1:22005
(node:430) ExperimentalWarning: The ESM module loader is experimental.
[M] Announcing into master server...
Loading packages
Initializing bridge (0.3.7.0)..
Initializing Bootstrapper.dll (0.3.7.0)..
-> SERVER STARTED AT 12/24/18 1:18:55 PM
[M] Connected to master list.
ACLEnabled: True
Loaded 451 entries from vehicleData.json
Loading resources..
-> Starting gtav.ee-rp resource..
gtav.ee-rp: loading scripts.. found 1 script(s)
gtav.ee-rp: instantiating gtav.framework.Main..
gtav.ee-rp: instantiating gtav.framework.Player..
gtav.ee-rp: instantiating gtav.framework.Veh..
gtav.ee-rp: instantiating gtav.framework.VehicleTuning..
gtav.ee-rp: loading server events.. found 22 server event(s)
gtav.ee-rp: loaded 22 server events(s)
gtav.ee-rp: loading commands.. found 319 command(s)
gtav.ee-rp: loaded 319 commands(s)
gtav.ee-rp: loading remote events.. found 219 remote event(s)
gtav.ee-rp: loaded 219 remote event(s)
SERVER RESOURCE STARTED!
SERVER START - 1
Aborted
[email protected]:/home/caupo/ragempx/ragemp-srv#

This line causes the Aborted:
 

NAPI.Vehicle.CreateVehicle(VehicleHash.Bmx, new Vector3(1237.934, -644.3236, 66.37692), new Vector3(-11.26651, 1.65399, 118.3276), 117, 117, "test-1", 255, true, false, 0);

I downloaded server files from this post.

Step by step what I did.
0. Installed apt-get stuff from here https://wiki.rage.mp/index.php?title=Getting_Started_with_Server
1. Downloaded files from post and extracted them.
2. I ran ragemp server process with default conf
3. Shut down the ragemp server process
3.1. Second time I tried from scratch then I uploaded the dependencies from post to my windows machine and compiled the project dll again.
4. Uploaded my project dll file to resource/project folder, MySql.Data.dll to /bridge/runtime and confed ragemp server
5. Ran ragemp server process.

Server itself is Debian 8, project dll is compiled on windows and uploaded through WinSCP, nothing comes to server_exceptions.txt file.

If any info is needed more, please let me know. I really want to solve this problem quickly as possible.

Share this post


Link to post
Share on other sites
1. sudo echo 'deb http://httpredir.debian.org/debian testing main contrib non-free' > /etc/apt/sources.list
2. apt-get update
3. apt-get install -y -t testing gcc
4. wget https://cdn.rage.mp/lin/ragemp-srv-037.tar.gz
5. tar -xzf ragemp-srv-037.tar.gz
6. cd ragemp-srv
7. chmod +x server
8. ./server
9. Downloaded my dll and put it to resources/my-project folder and added meta.xml with needed data to include gamemode dll file
10. apt-get install -y libunwind8 icu-devtools curl libssl-dev
11. wget https://cdn.rage.mp/lin/bridge-linux-037.tar.gz
12. tar -xzf bridge-linux-037.tar.gz
13. nano conf.json 
	added "csharp" : "enabled",
14. ./server 
	got an error that MySql.Data.dll is missing
15. Downloaded MySql.Data.dll and moved it to bridge/runtime folder
16. ./server
	Getting "Aborted" text.

This is the full list of commands which I executed to install ragemp server to my Debian 9 server in Virtualbox and I still get the same result "Aborted" text in console.

Share this post


Link to post
Share on other sites

Problem solved thanks to horsepin in Discord serverside-csharp text channel.

Problem was that Vehicle creation overload with rotation as a Vector3 object crashes the server. So use float instead.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.