Jump to content

`GLIBCXX_3.4.22' not found


Recommended Posts

./server: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.22' not found (required by ./server)
./server: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by ./server)
./server: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by ./server)


Any suggestion how to fix that error ?

Already installed gcc 4.9

Link to comment
Share on other sites

  • 3 months later...

How do I install this on Debian Jessie? I don't want to upgrade my sources to the next Debian version "Stretch", because there could occur incompatibilities with other packets installed. And compiling GCC-6 from resources didn't work properly and is probably too complicated.

Am 23.4.2017 um 09:30 schrieb CheS_64:

GCC 6 needed


Edited by comniemeer
Link to comment
Share on other sites

  • 2 weeks later...

To is now problem, but i can find fix (Ubuntu 14.04) (gcc old version 4.x.x, need upgrade)

First step: download gcc last version on site https://gcc.gnu.org/ (7.2) (use wget on server)

For setup requested other components (GMP, MPFR, MPC):

apt-get install libgmp3-dev libmpfr-dev libmpfr-doc libmpfr4 libmpfr4-dbg

MPC download: http://www.multiprecision.org/?prog=mpc&page=download (ftp://ftp.gnu.org/gnu/mpc/mpc-1.0.3.tar.gz) and unpack (configure, make, make install)

Is now... If server x64, use command: ./configure --disable-multilib, not simple ./configure.

Result if everything was correct


..... Okay. After use make, make install (cmd). Done.

Check GCC version: gcc -v (should be to work more > 6.x.x).



  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...