Sign in to follow this  
underground475

event problem

Recommended Posts

hi zusammen
ich habe ein problem mit meinem selbst erstellten event
wenn ich denn Server eine zahl schicken lasse funktioniert alles aber wenn es ein string ist funktioniert es nicht richtig hoffe mit kann jemand helfen

Server

[RemoteEvent("OnPlayerLoginAttempt")]
        public void OnPlayerLoginAttempt(Client player, string username)
        {

            Client gesuchterspieler = NAPI.Player.GetPlayerFromName(username);
            if (gesuchterspieler != null)
            {  
                String SNAME = gesuchterspieler.SocialClubName;
                
                player.TriggerEvent("LoginResult",SNAME);
            }
            
        }

Client

mp.events.add('LoginResult', (info) => {
mp.gui.chat.push("Server hat die info: "+info+" zurück geschickt"); 

speedo.execute(`update(${info});`); //  <-- wird nur ausgeführt wenn der Server eine Zahl schickt

});

CEF

function update(info)
{			
	sendinfotoserver(info);	
}
function setinfo(info)
{
	document.getElementById("infotext").innerHTML = "info: "+info;	
}
 

 

Share this post


Link to post
Share on other sites

Du triggerst das Event nur, wenn der gesuchtespieler gefunden wurde. (!= null). 

Gibst du einen String ein und der User wird nicht gefunden, gibt es keine Ausgabe. 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.