Stuffel

grpc support (Error: grpc_node.node: undefined symbol: deflate)

Recommended Posts

I've been trying to get grpc running, because of the depency in @google-cloud/firestore and other packages.

I've tried the normal installation of grpc and the build-from-source method, both didn't work unfortunately. When I run it with Node v11.1.0 without the RAGE MP server there are no issues. When I start the server and start to save data to Firestore (which triggers the grpc module) I get this error:

Error: /home/me/ragemp-srv/packages/firetest/node_modules/grpc/src/node/extension_binary/node-v67-linux-x64-glibc/grpc_node.node: undefined symbol: deflate
    at Object.Module._extensions..node (internal/modules/cjs/loader.js:736:18)
    at Module.load (internal/modules/cjs/loader.js:605:32)
    at tryModuleLoad (internal/modules/cjs/loader.js:544:12)
    at Function.Module._load (internal/modules/cjs/loader.js:536:3)
    at Module.require (internal/modules/cjs/loader.js:643:17)
    at require (internal/modules/cjs/helpers.js:22:18)
    at Object.<anonymous> (/home/me/ragemp-srv/packages/firetest/node_modules/grpc/src/grpc_extension.js:32:13)
    at Module._compile (internal/modules/cjs/loader.js:707:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:718:10)
    at Module.load (internal/modules/cjs/loader.js:605:32)

I'm running on Unbutu 18.04. I've tried it in Windows 10 also, which gave a different kind of error.

Any chance this is going to work? Would be awesome to create integrations with Google Cloud.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.