Sign in to follow this  
hash_

Problem with MySQL

Recommended Posts

Hello

 

Im trying to make a test script using MySQL

 

i ran into the following error while compiling and debugging and i couldn't find a solution for it.

 

-> Error starting 'LSGW-RMP'
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.IO.FileNotFoundException: Could not load file or assembly 'System.Security.Permissions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51'. The system cannot find the file specified.
   at MySql.Data.MySqlClient.MySqlConnection.AssertPermissions()
   at MySql.Data.MySqlClient.MySqlConnection.Open()
   at LSGW_RMP.Database.ConnectToDB(MySqlConnection connection) in E:\RAGEMPSERVER\server-files\bridge\resources\LSGW-RMP\Database.cs:line 29
   at LSGW_RMP.Database.DatabaseOnServerStart() in E:\RAGEMPSERVER\server-files\bridge\resources\LSGW-RMP\Database.cs:line 40
   at LSGW_RMP.Main.OnResourceStart() in E:\RAGEMPSERVER\server-files\bridge\resources\LSGW-RMP\Main.cs:line 12
   --- End of inner exception stack trace ---
   at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
   at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)
   at GTANetworkInternals.ScriptingEngine.InvokeVoidMethod(String method, Object[] args)
   at System.Collections.Generic.List`1.ForEach(Action`1 action)
   at GTANetworkInternals.EventHandler.ParseEx(Event _event, ScriptingEngine engine, Object[] arguments)
   at System.Collections.Generic.List`1.ForEach(Action`1 action)
   at GTANetworkInternals.GameServer.StartResource(String resourceName, String parent)

it's a problem when i try to Open the MySQL connection

edit : ive fixed it, apparently i must enable the option to copy local assembly files to the build directory which i haven't done.

ive found this slution in the tutorial section here

 

Edited by hash_
fixed

Share this post


Link to post
Share on other sites

k sorry to bump but ive fixed the issue above only to face another one

 

 

'Could not load file or assembly 'System.Security.Principal.Windows, Version=4.1.1.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'. Could not find or load a specific file. (Exception from HRESULT: 0x80131621)'

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.