Jump to content
RAGE Multiplayer Community

Problem to set up WiredPlayers


Recommended Posts

Hello,

First I want to apologize in advance for my bad English, I am French. I also want to thank Xabi for sharing his work.


I have an installation problem with the WiredPlayers server. To clarify my request, I am on Windows 10 and here is what I did in order:

- Download the latest version of WiredPlayers (with the paid option 5$ on Patreon, I think it's a good thing to pay creators, if my finances allowed, I will probably pay more)

- I use WAMP and I imported in order the files database_creation.sql, animations.sql and dealer_vehicles.sql

- To get the right version of RAGE, I modified the config.xml file by putting:

Quote

<?xml version="1.0" encoding="UTF-8"?>
<channel>10_mNwuchuQ4ktWbR8d2N5jUzRt</channel>

Then I run the updater.exe file

- Copy / paste all files in server-files

- Open the WiredPlayers.csproj solution in Visual Studio 2019

- Modify meta.xml to put root in username, my password and gtav in database

- Generate the solution, 0 errors and 3 warning:

f43f6084bb87dff34eacb6c3af117200.png

(in english: The assembly reference 'mscorlib.dll' targets a other processor)

- Save and close Visual Studio

- Run ragemp_server.exe but I have 2 errors:

6675eb53e97a23cf70e24dc5c195a5af.png

2f6aa9d27c5ff5b6b7a153db267f5cfa.png

 

Here I am blocked, if I add the file coreclr.dll in bridge\runtime or if I add the complete folder of bridge, the ragemp-server.exe run and close immediately.

I have maybe missed something because WiredPlayers.ressources.dll is not in server-files\dotnet\resources\WiredPlayers\bin\Debug\netcoreapp3.1\ but I don't see what, I have correctly regen the solution in Visual Studio.

After some research on the internet, I did not find a bridge version for RAGE 1.1 (if there is one I would like to have the link, I saw that Xabi had given the link https://cdn.gtanet.work/bridge-package.zip to users with problems, but it's a dead link now).

I thank in advance anyone who try help me to solve the problem.
 

Link to post
Share on other sites

Hello Xabi,

Thanks for your help, I have delete bridge.dll, however I have a other error with WiredPlayers.resources.dll : Could not load file WiredPlayers.resources.dll en WiredPlayers\bin\netcoreapp3.1\WiredPlayers.resources.dll

I copy/paste WiredPlayers.resources.dll who is in WiredPlayers\bin\Debug\netcoreapp3.1\es-ES\ to WiredPlayers\bin\netcoreapp3.1\ but when I start my game, I have this error:

62638bdf2dc14840b165e9c939de0900.png

 

I verify all my files (I'm on Windows 10, I have Visual C++ Redistribuable, I have no compatibility mode on me gtav.exe, etc..) but I don't see why I have this error.

Do you have an idea for this problem ?

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...