Jump to content
RAGE Multiplayer Community

Help! Trying to install RAGE on Manjaro Linux.


flyingthegame
 Share

Recommended Posts

Hello everyone, immediately excuse my English, unfortunately it is not very good.
Let's get down to business - I'm trying to install the RAGE Multiplayer client on my Manjaro Linux OS, but unfortunately I can't do it, if someone has information, can you share? I would be very grateful.

OS technical info: 
Manjaro Linux 21.0.7

 

Link to comment
Share on other sites

  • 4 weeks later...

Same problem. Using proton+epicgames, game just crashed after 0.1ms work. Trying all ways too :( (can you show your log?)


-------------------------------------------------------------
PortWINE version:
PortProton-90
------------------------------------------------------------
Scripts version:
1119
-----------------------------------------------------------
RUNTIME is enabled
----------------------------------------------------------
Debug for programm:
/home/glazkov/PortWINE/PortProton/data/pfx/drive_c/RAGEMP/ragemp_v.exe
---------------------------------------------------------
GLIBC version:
2.33
--------------------------------------------------------
PW_VULKAN_USE=dxvk_v.
------------------------------------------------------
Date and time of start debug for PortProton
Сб 17 июл 2021 00:28:56 MSK
-----------------------------------------------------
The installation path of the PortProton:
/home/glazkov/PortWINE/PortProton
----------------------------------------------------
Operating system
ОС:  Manjaro Linux
--------------------------------------------------
Desktop Environment
gnome
GNOME
Kernel
5.13.0-1-MANJARO
-------------------------------------------------
CPU
model name  : AMD Ryzen 7 5800X 8-Core Processor
------------------------------------------------
RAM
               total        used        free      shared  buff/cache   available
Mem:           32051       12167        6884        1328       12999       18096
Swap:          40959           0       40959
-----------------------------------------------
Graphic cards and drivers
name of display: :2
display: :2  screen: 0
direct rendering: Yes
Memory info (GL_NVX_gpu_memory_info):
    Dedicated video memory: 11264 MB
    Total available memory: 11264 MB
    Currently available dedicated video memory: 9532 MB
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: NVIDIA GeForce RTX 2080 Ti/PCIe/SSE2
OpenGL core profile version string: 4.6.0 NVIDIA 470.42.01
OpenGL core profile shading language version string: 4.60 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 4.6.0 NVIDIA 470.42.01
OpenGL shading language version string: 4.60 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)
OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 470.42.01
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
----------------------------------------------
Vulkan info device name:
  deviceName     = NVIDIA GeForce RTX 2080 Ti
Vulkan cube test passed successfully
--------------------------------------------
Version WINE in the Port
1624629470 proton-6.3-5
-------------------------------------------
winetricks.log:
d3dx9
d3dcompiler_47
w_workaround_wine_bug-24013
d3dcompiler_43
d3dcompiler_42
w_workaround_wine_bug-50894
vcrun2019
mfc42
vcrun6
vcrun6sp6
vcrun2013
vcrun2012
vcrun2010
w_workaround_wine_bug-34803
remove_mono
winxp
dotnet40
------------------------------------------
Use /home/glazkov/PortWINE/PortProton/data/scripts/portwine_db/ragemp_v db file:
#!/bin/bash
#Author: dez
#ragemp_v.exe
#updater.exe
#Rating=1-5
export PW_VULKAN_USE=dxvk
export PW_VIRTUAL_DESKTOP=1
export PW_DLL_INSTALL="dotnet40 vcrun2019"
-----------------------------------------
Log WINE:
gamemodeauto: 
esync: up and running.
wine: RLIMIT_NICE is <= 20, unable to use setpriority safely
vkBasalt info:  config file: /home/glazkov/PortWINE/PortProton/data/vkBasalt.conf
vkBasalt info:  reshadeTexturePath = /usr/local/share/reshade/Textures
vkBasalt info:  reshadeIncludePath = /usr/local/share/reshade/
vkBasalt info:  FakeMotionBlur = /usr/local/share/reshade/shaders/FakeMotionBlur.fx
vkBasalt info:  FXAA = /usr/local/share/reshade/shaders/FXAA.fx
vkBasalt info:  GaussianBlur = /usr/local/share/reshade/shaders/GaussianBlur.fx
vkBasalt info:  HQ4X = /usr/local/share/reshade/shaders/HQ4X.fx
vkBasalt info:  Layer = /usr/local/share/reshade/shaders/Layer.fx
vkBasalt info:  LevelsPlus = /usr/local/share/reshade/shaders/LevelsPlus.fx
vkBasalt info:  MagicBloom = /usr/local/share/reshade/shaders/MagicBloom.fx
vkBasalt info:  ReflectiveBumpMapping = /usr/local/share/reshade/shaders/ReflectiveBumpMapping.fx
vkBasalt info:  SMAA = /usr/local/share/reshade/shaders/SMAA.fx
vkBasalt info:  Tonemap = /usr/local/share/reshade/shaders/Tonemap.fx
vkBasalt info:  Vignette = /usr/local/share/reshade/shaders/Vignette.fx
vkBasalt info:  Curves = /usr/local/share/reshade/shaders/Curves.fx
vkBasalt info:  FakeHDR = /usr/local/share/reshade/shaders/FakeHDR.fx
vkBasalt info:  casSharpness = 0.75
vkBasalt info:  toggleKey = Home
vkBasalt info:  effects = FakeHDR:cas
MANGOHUD: Connected to D-Bus as ":1.5810".
0100:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
0110:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
MANGOHUD: Connected to D-Bus as ":1.5811".
021c:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
027c:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
029c:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
027c:err:openxr:HACK_does_openvr_work Could not create key, status 0x2.
027c:err:vulkan:X11DRV_vkCreateWin32SurfaceKHR Failed to allocate client window for hwnd=0x100b6
027c:err:seh:dispatch_exception Fatal unknown exception (code=21474343) raised
0348:err:seh:dispatch_exception Fatal EXCEPTION_WINE_CXX_EXCEPTION exception (code=e06d7363) raised
034c:err:winediag:WSASocketW Failed to create a socket of type SOCK_RAW, this requires special permissions.


INFO: process EpicGamesLauncher.exe is blacklisted in MangoHud
03c0:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
03c0:err:combase:RoGetActivationFactory Failed to find library for L"Windows.UI.ViewManagement.UISettings"
03c0:err:openxr:HACK_does_openvr_work Could not create key, status 0x2.
04d4:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
04d4:err:openxr:HACK_does_openvr_work Could not create key, status 0x2.
05e8:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
0634:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
0634:err:openxr:HACK_does_openvr_work Could not create key, status 0x2.
0690:err:esync:__esync_wait_objects Polling on fd 210 returned 0x20.
06fc:err:openxr:HACK_does_openvr_work Could not create key, status 0x2.
0808:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
INFO: process SocialClubHelper.exe is blacklisted in MangoHud
0808:err:combase:RoGetActivationFactory Failed to find library for L"Windows.UI.ViewManagement.UISettings"
0868:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
0890:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
08a4:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
0868:err:openxr:HACK_does_openvr_work Could not create key, status 0x2.
0868:err:vulkan:X11DRV_vkCreateWin32SurfaceKHR Failed to allocate client window for hwnd=0x1015e
0868:err:seh:dispatch_exception Fatal unknown exception (code=21474343) raised
0974:err:esync:__esync_wait_objects Polling on fd 232 returned 0x20.
06fc:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
09b4:err:ole:com_get_class_object apartment not initialised
wine: Read access denied for device L"\\??\\E:\\", FS volume label and serial are not available.
wine: Read access denied for device L"\\??\\F:\\", FS volume label and serial are not available.
wine: Read access denied for device L"\\??\\I:\\", FS volume label and serial are not available.
wine: Read access denied for device L"\\??\\J:\\", FS volume label and serial are not available.
09e4:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
0a04:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...