Jump to content
RAGE Multiplayer Community

Wine/Linux (Client)


tuxfoo
 Share

Recommended Posts

Hi there,

I realise that this is out of scope of RAGE mp but I would like to use RAGE MP via WINE on Linux.

GTA V runs smoothly on Linux via WINE/DXVK.

I have managed to get rage mp installed under my GTAV wine prefix.

When I run "ragemp_v.exe" I get "FATAL ERROR: Could not start RAGE Multiplayer". No surprise there, I did not expect it work.

WINEPREFIX=/PATH/TO/GTAPREFIX/ winetricks install dotnet462 dotnet472 vcrun2015
mkdir /PATH/TO/GTAPREFIX/RAGEMP/
cd /PATH/TO/GTAPREFIX/RAGEMP/
wget http://cdn.rage.mp/client/updater.exe
wget http://cdn.rage.mp/client/ragemp-web-installer.exe

Has any one managed to progress any further?

Does RAGEMP make use of shared resources like FIVEM? Because that is not supported by DXVK yet.

Kind Regards.

Link to comment
Share on other sites

56 minutes ago, Fachpersonal said:

Same Error on my system using Manjaro 18.0.2 using Mesa, Lutris with winesteam and dxvk 1.0.

About the shared resources, there is currently no way to implement it because wine does not support it. Doitsujin labeled it as "wontfix" ->  https://github.com/doitsujin/dxvk/issues/899

I am not sure that ragemp makes that API call. Hopefully not.

Link to comment
Share on other sites

  • 1 month later...
  • 2 years later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...