Jump to content
RAGE Multiplayer Community

Recommended Posts

Hello!

I've been playing Rage-MP for the last month and now I've decided to try and make my own server but unfortunately I've run into many problems and confusions so I'm writing here in hopes of solving them.

 

I'm currently hosting on ZAP-Hosting, and fortunately for me I can change between Windows and Linux, 0.3.7 and 1.1 versions of RageMP.

Now, my first confusion is, all resources and Wiki pages about starting a RageMP server is based on 1.1 version, for which I don't see a reason for now since if you want your server on masterlist it has to be 0.3.7 version.

Second thing is that I want to run CSharp scripts on my server, but I can't find anywhere 0.3.7 version of Bridge, and all Wiki posts refer to newest version which I cannot use on 0.3.7 version of server.

When I install version 0.3.7 on Windows and just enable CSharp in conf.json, server runs fine but I get this warning/error in console.

spacer.png

 

This is my bridge runtime folder (bridge folder is empty and only has runtime folder):

spacer.png

 

And this is my plugins folder:

spacer.png

 

 

I've tried finding some other Bridge version, but all versions just crash my server with segmentation fault on server.exe.

I'll be glad to try any solution you guys might have as I've been trying to solve this myself for over 24 hours now without success.

Link to post
Share on other sites
28 minutes ago, Xabi said:

Don't know where did you find the information but... following this link, you can find it:

https://wiki.rage.mp/index.php?title=Getting_Started_with_Server

Hello and thank you for your reply, I really appreciate it since I'm still having trouble with this. :)

 

Now on the topic, that's exactly where I found the information.

For now, I've downloaded 0.3.7 server from ZAP-Hosting and testing it on my own PC till I fix the issue.

I've got clean installation of Rage-MP on my PC, and when I run updater.exe I just get FATAL ERROR.

spacer.png

I guess that's because RageMP and server-files are version 1.1, but not entirely sure.

 

I've tried removing everything from "server-files" folder and importing my 0.3.7 server there, but I still get FATAL ERROR when trying to update with given updater.exe.

I've also tried to download bridge-package.zip which I tried importing on 0.3.7 version, everything starts up but whenever I connect on server it just crashes without any error message.

spacer.png

 

I've also tried putting bridge-package files in "server-files" and running updater, again I get FATAL ERROR.

Link to post
Share on other sites

You need to update the game, it's saying you're using 0.3.5 there...

Also if you're starting with the development now I wouldn't recommend using 0.3.7, just go straight to 1.1 version.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...